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問題:
バージョン3.4.3880以降の認証エージェントを導入すると、エージェントは常にユーザの認証に失敗します。
原因:
バージョン3.4.3880以降の認証エージェントは、初期設定ではADサーバへの接続にSSL/TLSを使用します。通信が成功するには、ADサーバが透過的TLSをサポートしている必要があります。サポートしていない場合、認証エージェントはADサーバに接続してユーザを認証することができません。
解決策:
  1. ADサーバで透過的TLSを有効化します。
  2. ADサーバが透過的TLSをサポートしていない場合は、認証エージェントのSSL/TLSを無効にして、エージェントがADサーバと正常に通信できるようにします。これを行うには、設定ファイル<Installation path>¥AuthenticationAgent¥simplesamlphp¥config¥authsources.phpを開き、パラメータenable_tlsの値をFALSEに変更します。