SQL Server 移轉工具線上說明

SQL Server 移轉工具 上層主題

管理員可使用 SQL Server 移轉工具將現有 OfficeScan 資料庫從其本機 CodeBase 樣式移轉至 SQL Server 資料庫。SQL Server 移轉工具支援下列資料庫移轉：
  • OfficeScan CodeBase 資料庫到新 SQL Server Express 資料庫
  • OfficeScan CodeBase 資料庫到先前存在的 SQL Server 資料庫
  • 移至其他位置的 OfficeScan SQL 資料庫（先前已移轉）
相關資訊
  • 使用 SQL Server 移轉工具
  • 設定 SQL 資料庫無法使用警訊
© 2018 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。


使用 SQL Server 移轉工具

Trend Micro homepage

SQL Server 移轉工具線上說明

使用 SQL Server 移轉工具 上層主題

SQL Server 移轉工具使用 SQL Server 2016 SP1 Express 將現有 CodeBase 資料庫移轉到 SQL 資料庫。
秘訣
秘訣
移轉 OfficeScan 資料庫之後，您可以將新移轉的 SQL 資料庫移動到其他 SQL Server。重新執行 SQL Server 移轉工具，然後選取「切換到現有 OfficeScan SQL 資料庫」，以使用其他 SQL Server。

程序

  1. 在 OfficeScan 伺服器電腦上，瀏覽至 <伺服器安裝資料夾>\PCCSRV\Admin\Utility\SQL。
  2. 按兩下 SQLTxfr.exe 執行此工具。
    「SQL Server 移轉工具」主控台隨即開啟。
  3. 選擇移轉類型：
    選項 說明
    安裝/建立新的 SQL Server 2016 SP1 Express 執行個體並移轉 OfficeScan 資料庫
    自動安裝 SQL Server 2016 SP1 Express 並將現有 OfficeScan資料庫移轉到新的 SQL 資料庫
    注意
    注意
    OfficeScan 會自動將通訊埠 1433 指派給 SQL Server。
    將 OfficeScan 資料庫移轉到現有 SQL Server
    將現有 OfficeScan 資料庫移轉到現有 SQL Server 上的新 SQL 資料庫
    切換到現有 OfficeScan SQL 資料庫
    變更 OfficeScan 組態設定以指向現有 SQL Server 上的現有 OfficeScan SQL 資料庫
  4. 按照下列方式指定「伺服器名稱」：
    • 全新 SQL 安裝：<SQL Server 的主機名稱或 IP 位址>\<實體名稱>
    • SQL Server 移轉：<SQL Server 的主機名稱或 IP 位址>,<通訊埠號碼>\<實體名稱>
    • 切換到現有的 OfficeScan SQL 資料庫：<SQL Server 的主機名稱或 IP 位址>,<通訊埠號碼>\<實體名稱>
    重要
    重要
    安裝 SQL Server 時，OfficeScan 會自動建立 OfficeScan 資料庫實體。移轉至現有 SQL Server 或資料庫時，請在 SQL Server 上輸入 OfficeScan 實體的先前存在的實體名稱。
  5. 提供 SQL Server 資料庫的驗證憑證。
    • 使用「Windows 帳號」登入伺服器時，「使用者名稱」必須使用下列格式：
      domain_name\user_name 或 user_name
      重要
      重要
      使用者帳號必須屬於本機管理員群組或 Active Directory (AD) 內建管理員，而您必須使用 Windows「本機安全性原則」或「群組原則管理」主控台設定「使用者權限指派」中的下列原則：
      • 以服務方式登入
      • 以批次工作登入
      • 本機登入
      使用者帳號還必須具有下列資料庫角色：
      • dbcreator
      • bulkadmin
      • db_owner
  6. 針對新 SQL Server 安裝，輸入新密碼並確認。
    注意
    注意
    密碼必須符合下列最低強度需求：
    1. 最小長度：8 個字元
    2. 必須至少包含下列 3 個字元：
      • 大寫字母：A - Z
      • 小寫字母：a - z
      • 數字： 0 - 9
      • 特殊字元： !@#$^*?_~-();.+:
  7. 指定 SQL Server 上 OfficeScan 的「資料庫名稱」。
    將 OfficeScan CodeBase 資料庫移轉至新的 SQL 資料庫時，OfficeScan 會自動使用提供的名稱建立新資料庫。
  8. 或者，執行下列工作：
    • 請點選「測試連線」，確認現有 SQL Server 或資料庫的驗證憑證。
    • 請點選「SQL 資料庫無法使用警訊...」，設定 SQL 資料庫通知設定。
      如需詳細資訊，請參閱設定 SQL 資料庫無法使用警訊。
  9. 請點選「開始」，套用組態變更。
© 2018 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。


設定 SQL 資料庫無法使用警訊

Trend Micro homepage

SQL Server 移轉工具線上說明

設定 SQL 資料庫無法使用警訊 上層主題

每當 SQL 資料庫無法使用時，OfficeScan 會自動傳送此警訊。
警告
警告
當資料庫變得不可用時，OfficeScan 會自動停止所有服務。當資料庫不可用時，OfficeScan 無法記錄用戶端或事件資訊、執行更新或設定用戶端。

程序

  1. 在 OfficeScan 伺服器電腦上，瀏覽至 <伺服器安裝資料夾>\PCCSRV\Admin\Utility\SQL。
  2. 按兩下 SQLTxfr.exe 執行此工具。
    「SQL Server 移轉工具」主控台隨即開啟。
  3. 請點選「SQL 資料庫無法使用警訊...」。
    「SQL Server 無法使用警訊」畫面隨即開啟。
  4. 輸入警訊收件者的電子郵件信箱。
    請使用半形分號 (;) 來分隔多個項目。
  5. 視需要修改「主旨」和「訊息」。
    OfficeScan 提供下列 Token 變數：

    SQL 資料庫無法使用警訊 Token

    變數
    說明
    %x
    OfficeScan SQL Server 實體的名稱
    %s
    受影響的 OfficeScan 伺服器的名稱
  6. 請點選「確定」。
© 2018 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。