SQL Server 마이그레이션 도구 온라인 도움말

SQL Server 마이그레이션 도구 상위 항목

관리자는 SQL Server 마이그레이션 도구를 사용하여 기존 OfficeScan 데이터베이스를 기본 CodeBase 스타일에서 SQL Server 데이터베이스로 마이그레이션할 수 있습니다. SQL Server 마이그레이션 도구는 다음과 같은 데이터베이스 마이그레이션을 지원합니다.
  • OfficeScan CodeBase 데이터베이스에서 새 SQL Server Express 데이터베이스로
  • OfficeScan CodeBase 데이터베이스에서 기존 SQL Server 데이터베이스로
  • 다른 위치로 이동한 OfficeScan SQL 데이터베이스(이전에 마이그레이션함)
관련 정보
  • SQL Server 마이그레이션 도구 사용
  • SQL 데이터베이스를 사용할 수 없음 경고 구성
© 2018 Trend Micro Incorporated. All Rights Reserved.


SQL Server 마이그레이션 도구 사용

Trend Micro homepage

SQL Server 마이그레이션 도구 온라인 도움말

SQL Server 마이그레이션 도구 사용 상위 항목

SQL Server 마이그레이션 도구는 SQL Server 2016 SP1 Express를 사용하여 기존 CodeBase 데이터베이스를 SQL 데이터베이스로 마이그레이션합니다.
팁
팁
OfficeScan 데이터베이스를 마이그레이션한 후에는 새로 마이그레이션한 SQL 데이터베이스를 다른 SQL Server로 이동할 수 있습니다. SQL Server 마이그레이션 도구를 다시 실행하고 기존 OfficeScan SQL 데이터베이스로 전환을 선택하여 다른 SQL Server를 사용합니다.

절차

  1. OfficeScan 서버 컴퓨터에서 <서버 설치 경로>\PCCSRV\Admin\Utility\SQL로 이동합니다.
  2. SQLTxfr.exe를 두 번 클릭하여 도구를 실행합니다.
    SQL Server 마이그레이션 도구 콘솔이 열립니다.
  3. 마이그레이션 유형을 선택합니다.
    옵션 설명
    새 SQL Server 2016 SP1 Express 인스턴스를 설치/생성하고 OfficeScan 데이터베이스 마이그레이션
    SQL Server 2016 SP1 Express를 자동으로 설치하고 기존 OfficeScan 데이터베이스를 새 SQL 데이터베이스로 마이그레이션합니다.
    참고
    참고
    OfficeScan은 SQL Server에 포트 1433을 자동으로 할당합니다.
    기존 SQL Server로 OfficeScan 데이터베이스 마이그레이션
    기존 SQL Server의 새 SQL 데이터베이스로 기존 OfficeScan 데이터베이스 마이그레이션합니다.
    기존 OfficeScan SQL 데이터베이스로 전환
    기존 SQL Server의 기존 OfficeScan SQL 데이터베이스를 가리키도록 OfficeScan 구성 설정을 변경합니다.
  4. 다음과 같이 서버 이름을 지정합니다.
    • SQL을 새로 설치하는 경우: <SQL 서버의 호스트 이름 또는 IP 주소>\<인스턴스 이름>
    • SQL Server를 마이그레이션하는 경우: <SQL 서버의 호스트 이름 또는 IP 주소>,<포트 번호>\<인스턴스 이름>
    • 기존 OfficeScan SQL 데이터베이스로 전환하는 경우: <SQL 서버의 호스트 이름 또는 IP 주소>,<포트 번호>\<인스턴스 이름>
    중요
    중요
    OfficeScan에서는 SQL Server가 설치될 때 OfficeScan 데이터베이스의 인스턴스를 자동으로 만듭니다. 기존 SQL Server 또는 데이터베이스로 마이그레이션할 경우 SQL Server에 있는 OfficeScan 인스턴스의 기존 인스턴스 이름을 입력합니다.
  5. SQL Server 데이터베이스에 대한 인증 자격 증명을 제공합니다.
    • Windows 계정을 사용하여 서버에 로그인하는 경우 사용자 이름은 다음 형식을 사용해야 합니다.
      domain_name\user_name 또는 user_name
      중요
      중요
      사용자 계정은 로컬 관리자 그룹 또는 AD(Active Directory) 기본 제공 관리자에 속해야 하며 Windows 로컬 보안 정책 또는 그룹 정책 관리 콘솔을 사용하여 다음의 사용자 권한 할당 정책을 구성해야 합니다.
      • 서비스로 로그온
      • 배치 작업으로 로그온
      • 로컬 로그온
      사용자 계정에는 다음과 같은 데이터베이스 역할이 있어야 합니다.
      • dbcreator
      • bulkadmin
      • db_owner
  6. SQL Server를 새로 설치하는 경우 새 암호를 입력하고 확인합니다.
    참고
    참고
    암호는 다음과 같은 최소 강도 요구 사항을 충족해야 합니다.
    1. 최소 길이: 8자
    2. 다음 중 3가지 이상을 포함해야 합니다.
      • 대문자: A~Z
      • 소문자: a~z
      • 숫자: 0~9 0 - 9
      • 특수 문자: !@#$^*?_~-();.+: !@#$^*?_~-();.+:
  7. SQL Server의 OfficeScan 데이터베이스 이름을 지정합니다.
    OfficeScan CodeBase 데이터베이스를 새 SQL 데이터베이스로 마이그레이션할 경우 OfficeScan에서는 자동으로 새 데이터베이스를 제공한 이름으로 만듭니다.
  8. 필요한 경우 다음 작업을 수행합니다.
    • 연결 테스트를 클릭하여 기존 SQL Server 또는 데이터베이스의 인증 자격 증명을 확인합니다.
    • SQL 데이터베이스 사용할 수 없는 경고... 를 클릭하여 SQL 데이터베이스 알림 설정을 구성합니다.
      자세한 내용은 SQL 데이터베이스를 사용할 수 없음 경고 구성를 참조하십시오.
  9. 시작을 클릭하여 구성 변경 사항을 적용합니다.
© 2018 Trend Micro Incorporated. All Rights Reserved.


SQL 데이터베이스를 사용할 수 없음 경고 구성

Trend Micro homepage

SQL Server 마이그레이션 도구 온라인 도움말

SQL 데이터베이스를 사용할 수 없음 경고 구성 상위 항목

OfficeScan에서는 SQL 데이터베이스를 사용할 수 없는 경우 항상 이 알림을 자동으로 보냅니다.
경고
경고
OfficeScan에서는 데이터베이스를 사용할 수 없는 경우 서비스를 모두 자동으로 중지합니다. 데이터베이스를 사용할 수 없으면 OfficeScan에서 에이전트 또는 이벤트 정보를 기록하거나, 업데이트를 수행하거나, 에이전트를 구성할 수 없습니다.

절차

  1. OfficeScan 서버 컴퓨터에서 <서버 설치 경로>\PCCSRV\Admin\Utility\SQL로 이동합니다.
  2. SQLTxfr.exe를 두 번 클릭하여 도구를 실행합니다.
    SQL Server 마이그레이션 도구 콘솔이 열립니다.
  3. SQL 데이터베이스를 사용할 수 없음 경고…를 클릭합니다.
    SQL Server를 사용할 수 없음 경고 화면이 열립니다.
  4. 알림을 받는 사람의 전자 메일 주소를 입력합니다.
    항목이 여럿이면 세미콜론(;)으로 구분합니다.
  5. 필요한 경우 제목 및 메시지를 수정합니다.
    OfficeScan에서는 다음과 같은 토큰 변수를 제공합니다.

    SQL 데이터베이스를 사용할 수 없음 경고 토큰

    변수
    설명
    %x
    OfficeScan SQL 서버 인스턴스의 이름
    %s
    영향받는 OfficeScan 서버의 이름
  6. 확인을 클릭합니다.
© 2018 Trend Micro Incorporated. All Rights Reserved.