Aide en ligne de l'outil de migration SQL Server

Outil de migration SQL Server Sujet parent

Les administrateurs peuvent utiliser l'outil de migration SQL Server pour faire migrer la base de données OfficeScan existante de sa structure CodeBase native vers une base de données SQL Server. L'outil de migration SQL Server prend en charge les migrations de bases de données suivantes :
  • D'une base de données CodeBase OfficeScan vers une nouvelle base de données SQL Server Express
  • D'une base de données CodeBase OfficeScan vers une base de données SQL Server existant déjà
  • D'une base de données SQL OfficeScan (précédemment migrée) déplacée vers un autre emplacement
Information associée
  • Utilisation de l'outil de migration SQL Server
  • Configuration de l'alerte d'indisponibilité de la base de données SQL
©2018 Trend Micro Incorporated. Tous droits réservés.


Utilisation de l'outil de migration SQL Server

Trend Micro homepage

Aide en ligne de l'outil de migration SQL Server

Utilisation de l'outil de migration SQL Server Sujet parent

L'outil de migration SQL Server migre la base de données CodeBase existante vers une base de données SQL à l'aide de SQL Server 2016 SP1 Express.
Conseil
Conseil
Une fois la migration de la base de données OfficeScan effectuée, vous pouvez déplacer la base de données SQL récemment migrée vers un autre serveur SQL. Exécutez à nouveau l'outil de migration SQL Server et sélectionnez Passer à une base de données SQL OfficeScan existante pour utiliser l'autre serveur SQL.

Procédure

  1. Sur l'ordinateur serveur OfficeScan, accédez au répertoire <dossier d'installation du serveur>\PCCSRV\Admin\Utility\SQL.
  2. Double-cliquez sur le fichier SQLTxfr.exe pour exécuter l'outil.
    La console de l'Outil de migration SQL Server s'ouvre.
  3. Sélectionnez le type de migration :
    Option Description
    Installer/Créer une nouvelle instance de SQL Server 2016 SP1 Express et migrer la base de données OfficeScan
    Installe automatiquement SQL Server 2016 SP1 Express et migre la base de données OfficeScan existante vers une nouvelle base de données SQL.
    Remarque
    Remarque
    OfficeScan affecte automatiquement le port 1433 au serveur SQL.
    Migrer la base de données OfficeScan vers une instance SQL Server existante
    Migre la base de données OfficeScan existante vers une nouvelle base de données SQL sur un serveur SQL existant
    Passer à une base de données SQL OfficeScan existante
    Modifie les paramètres de configuration d'OfficeScan afin de pointer vers une base de données SQL OfficeScan existante sur un serveur SQL existant
  4. Spécifiez le Nom du serveur comme suit :
    • Pour de nouvelles installations SQL : <nom d'hôte ou adresse IP du serveur SQL Server>\<nom de l'instance>
    • Pour des migrations de serveurs SQL : <nom d'hôte ou adresse IP du serveur SQL>,<numéro_port>\<nom de l'instance>
    • Lors du basculement vers une base de données SQL OfficeScan existante : <nom d'hôte ou adresse IP du serveur SQL Server>,<numéro_port>\<nom de l'instance>
    Important
    Important
    OfficeScan crée automatiquement une instance de la base de données OfficeScan lors de l'installation du serveur SQL. Lors de la migration vers un serveur ou une base de données SQL existant(e), saisissez le nom de l'instance existante d'OfficeScan sur le serveur SQL.
  5. Fournissez les informations d'authentification de la base de données du serveur SQL.
    • Lors de l'utilisation d'un Compte Windows pour la connexion au serveur, le Nom d'utilisateur doit être au format suivant :
      nom_domaine\nom_utilisateur ou nom_utilisateur
      Important
      Important
      Le compte d'utilisateur doit appartenir au groupe administrateur local ou à l'administrateur Active Directory intégré, et vous devez configurer les stratégies d'attribution des droits d'utilisateur suivants à l'aide de la console Windows Stratégie de sécurité locale ou Gestion des stratégies de groupe :
      • Ouvrir une session en tant que service
      • Ouvrir une session en tant que tâche
      • Ouvrir une session locale
      Le compte d’utilisateur doit également disposer des rôles de base de données suivants :
      • dbcreator
      • bulkadmin
      • db_owner
  6. Pour les nouvelles installations de serveur SQL, saisissez un nouveau mot de passe, puis confirmez-le.
    Remarque
    Remarque
    Les mots de passe doivent répondre aux critères minimaux suivants :
    1. Longueur minimale : 8 caractères
    2. Ils doivent contenir au moins 3 des éléments suivants :
      • Lettres majuscules : A - Z
      • Lettres minuscules : a - z
      • Chiffres : 0 - 9 0 - 9
      • Caractères spéciaux : !@#$^*?_~-();.+: !@#$^*?_~-();.+:
  7. Spécifiez le OfficeScan Nom de la base de données sur le serveur SQL Server.
    Lors de la migration de la base de données CodeBase OfficeScan vers une nouvelle base de données SQL, OfficeScan crée automatiquement une base de données portant le nom indiqué.
  8. Vous avez éventuellement la possibilité d'effectuer les tâches suivantes :
    • Cliquez sur Tester la connexion pour vérifier les informations d'authentification du serveur ou de la base de données SQL existant(e).
    • Cliquez sur Alerte d'indisponibilité de la base de données SQL… pour configurer les paramètres de notification de la base de données SQL.
      Pour obtenir des informations détaillées, consultez la section Configuration de l'alerte d'indisponibilité de la base de données SQL.
  9. Cliquez sur Démarrer pour appliquer les modifications de la configuration.
©2018 Trend Micro Incorporated. Tous droits réservés.


Configuration de l'alerte d'indisponibilité de la base de données SQL

Trend Micro homepage

Aide en ligne de l'outil de migration SQL Server

Configuration de l'alerte d'indisponibilité de la base de données SQL Sujet parent

OfficeScan envoie automatiquement cette alerte lorsque la base de données SQL devient indisponible.
AVERTISSEMENT
AVERTISSEMENT
OfficeScan arrête automatiquement tous les services lorsque la base de données n'est plus disponible. Il ne peut pas consigner d'informations relatives aux agents ou aux événements, effectuer des mises à jour ou configurer des agents lorsque la base de données n'est pas disponible.

Procédure

  1. Sur l'ordinateur serveur OfficeScan, accédez au répertoire <dossier d'installation du serveur>\PCCSRV\Admin\Utility\SQL.
  2. Double-cliquez sur le fichier SQLTxfr.exe pour exécuter l'outil.
    La console de l'Outil de migration SQL Server s'ouvre.
  3. Cliquez sur Alerte d'indisponibilité de la base de données SQL....
    L'écran Alerte d'indisponibilité de l'instance SQL Server s'ouvre.
  4. Saisissez les adresses électroniques des destinataires de l'alerte.
    Séparez les entrées multiples par des points virgules (;).
  5. Modifiez les champs Objet et Message si nécessaire.
    OfficeScan fournit les variables de jeton suivantes :

    Jetons d'alerte d'indisponibilité de la base de données SQL

    Variable
    Description
    %x
    Nom de l'instance SQL Server OfficeScan
    %s
    Nom du serveur OfficeScan affecté
  6. Cliquez sur OK.
©2018 Trend Micro Incorporated. Tous droits réservés.


Index

Trend Micro homepage

Aide en ligne de l'outil de migration SQL Server

©2018 Trend Micro Incorporated. Tous droits réservés.